Solved

Server 2012 R2 Agent Service Fails to Start

  • 12 June 2024
  • 2 replies
  • 46 views

Badge

I’ve recently noticed that when our 2012 R2 servers restart the Automox Agent service does not automatically start. The service on each server is set to “Automatic” but this fails to happen. Checking the event log I see the Error below. Is this a known issue for Automox on Server 2012 R2, or could this be something specific to our environment?

 

During the boot process this event is logged:

“A timeout was reached (300000 milliseconds) while waiting for the Automox Agent service to connect.”

 

After logging in I can manually start the Automox Agent service without issue, it’s just not ideal to need to do that each time the servers restart.

icon

Best answer by JohnG-Automox 12 June 2024, 17:18

View original

2 replies

Userlevel 3

Hi @Nick S !

 

I can’t say I’m aware of that specific issue, so you may want to open a ticket with help.automox.com to further investigate the root cause.


In the immediate, you can use the following Catalog Worklet to ensure that the Automox Agent service’s Startup type is set to Delayed Automatic. This should allow core Windows services to start prior to the amagent service and prevent timeouts like you described:

Windows - Configuration - Set Service Startup Type

 

Additionally, the Scheduled Tasks to Stop and Restart a Service worklet will allow you to automate creating a scheduled task that restarts a target service daily at a defined time.

 

Both of these worklets will require some parameter input, so please read through their descriptions and implement accordingly.

 

You’ll obviously also need the amagent service to be in a started start and the device Connected within your console first to be able to use them.

 

I hope that helps!

 

Let me know if you have any other questions.

 

Badge

Hi @JohnG-Automox 

Thank you for the suggestion. After some testing we found the service started up without error when we change it to a delayed start. We will push this out to all of our 2012 R2 servers to keep updates going smoothly!

Thanks!

Reply