NEW KB: How to Create a Gold Image VM

  • 3 September 2020
  • 4 replies
  • 235 views

Badge

For those of you deploying Automox via your image deployment software, here’s instructions on how to setup Automox for the gold image to avoid duplicates showing up in the console.

https://support.automox.com/help/how-to-create-a-gold-image-vm


This topic has been closed for comments

4 replies

Userlevel 4

If you use an automation process to deploy your images, you may also consider disabling the Automox service before shutting down and collecting your image. This will provide an opportunity for you to start the service at a point in your build process when you are ready for Automox to become active.

I made the mistake of not shutting down or deregistering the agent before I cloned. How do I remove duplicates in this situation? I am unsuccessful in registering the agent on my newly cloned machines.

Userlevel 4

There are a couple of useful documents. The Gold image document above in the string is accurate to remediation as well if your clone is Windows-based. You will want to deregister each device and restart the Automox agent.

In addition, please take a look at the command line guide section on assigning a group to a device: https://support.automox.com/help/agent-command-line-guide#assigning-a-group-to-a-device

You can skip step 1 (unless you want to add the device to a group). Apply steps 2 and 3 to deregister your device and then restart the service (examples for each OS are in step 3). You can also reboot after step 2 if you prefer rather than restart the service.


PLEASE NOTE: if you do not generalize your image, the device may still identify the clones as the original system. The steps above will clear up the problem if you generalized the image, but just need to reset the Automox agent.

This was helpful and now I have my agents registered with the new machine name. Thanks for your help.