Ansible Playbook linked in documentation working?

  • 5 October 2020
  • 4 replies
  • 28 views

This link from the documentation redirects me to the home page. Is the playbook still available for download?



https://go.automox.com/hubfs/Technical%20Docs/get-automox.yml



4 replies

Badge

Hi Robert! Thank you for making us aware of this broken link. We’re working on a fix right now.

Badge

The docs have been updated. Thanks again for letting us know about that!

Userlevel 7

I’ve also given you the Bug Finder badge @RobertB, and shoot me a PM if you’d like some Automox swag as a thank you as well.

Badge

I wanted to post a quick addition to this - I found an error in the playbook and in the command listed in the kb article:

https://support.automox.com/help/deploying-the-automox-agent-in-bulk

Deploying with Ansible
You can distribute the Automox agent with Ansible using the Ansible playbook: get-automox.yml. Contact Automox Support for further assistance.

From the directory where the ‘get-automox.yml’ file is located, invoke the playbook with the following command, substituting your unique user key (zone key) as indicated: 

ansible-playbook get-automox.yml --extra-vars "zone=YOUR-ZONE-KEY-HERE

 

 

In get-automox.yml:

    - name: Ensure amagent is enabled and started
      service: 
        name: amagent 
        state: running <- Causes the playbook to fail.
        enabled: yes

state: running is not a valid state.  
Changing it to state: started fixes the problem.

 

Also, the command fails: ansible-playbook get-automox.yml --extra-vars "zone=YOUR-ZONE-KEY-HERE

 

Changing the command to
ansible-playbook -i hosts get-automox.yml --extra-vars “organization=ZONE_KEY”

The variable zone does not exist, I think it may have been updated but the documentation doesn’t reflect the change.  Also the command is missing a trailing double quote.

In get-automox.yml:

  vars:
    automox_url: https://console.automox.com/downloadInstaller?accesskey={{ organization }} 

The organization variable is where the zone variable would be. 
 

Reply