Issue with reinstalling agent on CentOS 7 linux

  • 28 July 2023
  • 1 reply


I have 4 CentOS 7 servers which are acting as app connectors for Zscaler Private Access. I wanted to install automox on them so the underlying OS can be patched along with our regular patching schedule.


The installation worked fine but then the agent lost connection to the console. I am trying to reinstall the agent according to the instructions here:


I have already removed the boxes from the console but since the server isnt communicating with the console, it doesnt appear to be removing the agent.


When i run the cmd

sudo /opt/amagent/amagent --deregister


I get the following error:

/opt/amagent/amagent: /lib64/ version `GLIBC_2.28' not found (required by /opt/amagent/amagent)


From what i can find, it seems that CentOS7 only supports GLIBC_2.17, but automox indicates that CentOS7 is a supported OS:


Any help would be appreciated.



1 reply

Userlevel 5

Hi @taylor.jones! Our support team might be able to dig in deeper and help you here. You can submit a support ticket via the customer portal (find more help here).