Worklet to install Enercalc

I’m working on a worklet to install Enercalc. In the documentation it says to run it unattended to use:

ECSEL6_SETUP.EXE /S /Q /V PAC “my_PCC_CODE_HERE”

I wrote just a quick and dirty oneliner to just to see if I could get it to work as I never wrote a worklet before. I came up with:

Start-Process -FilePath 'ecsel20_setup.exe' -ArgumentList ('/s', '/q', '/v', "_PAC_", '"MY_PCC_CODE_HERE"') -Wait -Passthru

In a powershell, it works great and install. I decided to test it on a worklet and something interesting happened.

During the install of Enercalc, if you don’t have the Microsoft VC++ redistributables installed on the PC it automatically installs them. So the Enercalc install automatically installed all of them on my test machine, except didn’t install Enercalc.

I’m really not sure where to go to try and figure out what’s going on, but a thought that I have is that during the install of Enercalc it displays an install screen during install, but I’m not sure if that would affect this or not.

Any help in pointing me in the right direction would be appreciated.

If it is successfully installing the Microsoft VC++, what happens if you run the policy again on the same machine? It may be as simple as running the install, check to see if the software is installed, if not, run it again all in the same policy. I have had to do some creative things with some of our oddball software. The Arduino software, I had to install it manually on a machine and export the certificates, then package the certs and the software in the policy. I’d then have the policy install the certs first and then the software. You could also look at checking for VC++ and installing that first if it doesn’t exist then kicking off your software install.

I tried that and it didn’t install a second time. It’s just weird that it automatically installs the VC++ Redistributables just fine but not the app itself. – You would think since those work everything would work.