Required Software Policy (Normal install location is appdata)

I’m hoping someone has already dealt with this.
Trying to push an install with Automox to several laptops at once. My issue is with the install location. Some programs are made to use AppData as an install path. It avoids admin privs and I believe makes it easier for users to customize their environment variables around the program.
Well, when Automox pushes stuff, it doesn’t seem to care so much who is logged in, so people with limited privs wouldn’t see it post-install.

Can someone clarify or even better, if you’ve come across this, post your story?

You wouldn’t happen to be talking about Microsoft Teams, would you? I know Teams is one of the apps we use that installs to the AppData location. I HATE that. It’s 2019 and nothing should be installing to that location.

The agent, and any code it runs, runs as the system account which would explain why it doesn’t care who is logged in when the install happens. Let me check with some folks here and see if they’re run into this particular situation before.

1 Like

What software are you trying to install? If the installer executable takes a parameter to specify the location then that should work, but I don’t think there’s a blanket answer in this case.

1 Like

Yeah I was definitely hoping (praying/crossing fingers and toes) for a blanket answer but figured it would come down to the individual programs install parm’s.

This particular case is Python 3.7.x

1 Like

If it is installing to the AppData directory then it likely doesn’t have any parameter support to point it to another directory. They use that location specifically to skirt around some of the restrictions that Program Files has in place. They’re also usually user-specific, if I recall.

Some apps will have an installation argument like “ALLUSERS=1” to install as a system-level app rather than a user-level app. But this is unfortunately different for every vendor/app.

1 Like

I did see the ALLUSERS flag come up for Python in a couple Google searches, but the install was failing when pushed via Automox using that flag. I just assumed it was deprecated and opened up shop here in this thread. :slight_smile:

1 Like

This blog post suggests that the flag might be called InstallAllUsers instead of AllUsers:
http://eddiejackson.net/wp/?p=10276

They have a bunch of other flags listed that might be useful too, such as TargetDir.

1 Like

Thanks Nic,
I’m testing a couple of those parameters now.

1 Like

Sure thing - let us know how it goes!

Also if you get the installation worklet working, would you be up for sharing it on the community?

1 Like

Doesn’t recognize those arguments. And sure, I don’t mind sharing.

1 Like

Bummer. I’ll keep digging around and see what else I can find.

1 Like

Ok I spent some time working on this and I think I have it figured out.

I used the following code in the Remediation section:

.\python-3.7.4.exe /quiet InstallAllUsers=1 PrependPath=1 Include_test=0 TargetDir=c:\Python374

You have to download the python-3.7.4.exe file and upload it using the Installation File button.

I left the Evaluation code blank and just did the Execute Now command on the policy (which ignores the Evaluation section anyway).

After installation both an admin user and a regular user were able to get to the c:\Python374 directory and run the python executable to get to the python command line.

Let me know if that works for you and if so then I’ll write this up with some evaluation code and in Powershell syntax.

1 Like