Automox agent bulk deployment with JumpCloud

Is there a typo at the following page https://docs.automox.com/home/agent-installation/deploying-the-automox-agent-in-bulk#deploying-with-jumpcloud ?
I’ve followed the instructions, but when I run the command through a Windows System managed by Jumpcloud I get the following error:
The term ‘sudo’ is not recognized as the name of a cmdlet, function, script file, or opera
ble program.
The example of the command from Automox document is curl -sS https://console.automox.com/downloadInstaller?accesskey=Your-Organization-Key-Here | sudo bash service amagent start
Is “sudo bash” not required?
Thanks,

Hi,

That command refers to the installation for the Linux. The script you are looking for is the Install-AxAgentMsi.ps1 and the full command to call that script would be

Install-AxAgentMsi.ps1 -AccessKey xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

Thank You,
Steven P

When I run it i get the following error message:
Install-AxAgentMsi.ps1 : The term ‘Install-AxAgentMsi.ps1’ is not recognized as the name of a cmd
let, function, script
file, or operable program. Check the spelling of the name, or if a path was included, verify that
the path is correct
and try again.
At line:1 char:1

  • Install-AxAgentMsi.ps1 -AccessKey xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx …
  •   + CategoryInfo          : ObjectNotFound: (Install-AxAgentMsi.ps1:String) [], CommandNotFound
    

Exception
+ FullyQualifiedErrorId : CommandNotFoundException

File destination for Install-AxAgentMsi.ps1
is C:\Windows\Temp\Install-AxAgentMsi.ps1

Hi,

Can you email me at steven.petrov@automox.com, we can setup a screenshare so that we can get this resolved.

Thank You,
Steven P

Hi Steven,
Tried to reach out to you. Let me know when works the best for you.
Thanks,

Why not put the powershell script directly into the command body inside JC.

What would be the script commands?

The contents of the powershell script. Jumpcloud has a checkbox to run as powershell command (32bit powershell)

FYI, Character limit is 2k if you insert command inside webgui. The automox onboarding not likely would exceed that.