Question

Rocky Linux Support

  • 2 February 2022
  • 4 replies
  • 117 views

Userlevel 1

With the move of CentOS8 to stream Rocky Linux has come out to replace it as the go to RHEL Clone.  When can we expect to see Rocky Linux as a supported OS?  Currently it detects Rocky Linux as SUSE which is weird as I would think it should detect it as CentOS or RHEL.


4 replies

Hey, Scott - I haven’t heard anything specific, but I can do some digging & ask around to see if it’s on the roadmap. 

Hi, Scott - I talked to one of our Sr. Tech. PM’s last week, and he’s running it by some engineers. I’ll let you know what I find out!

Bump, still unable to install for Rocky Linux 8, here is the error:

Installing package...
bash: line 297: zypper: command not found

Any update of Rocky Linux support for Automox?

Bump, still unable to install for Rocky Linux 8, here is the error:

Installing package...
bash: line 297: zypper: command not found

Any update of Rocky Linux support for Automox?

I successfully installed manually 

 

[root@rocky8_5 ~]# wget https://console.automox.com/installers/amagent-1.42.13-1.x86_64.systemd.rpm
--2023-02-03 09:54:07-- https://console.automox.com/installers/amagent-1.42.13-1.x86_64.systemd.rpm
Resolving console.automox.com (console.automox.com)... 54.191.17.161, 52.38.223.226, 54.187.163.42
Connecting to console.automox.com (console.automox.com)|54.191.17.161|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/octet-stream]
Saving to: ‘amagent-1.42.13-1.x86_64.systemd.rpm’

amagent-1.42.13-1.x86_64.systemd [ <=> ] 2.80M 5.95MB/s in 0.5s

2023-02-03 09:54:08 (5.95 MB/s) - ‘amagent-1.42.13-1.x86_64.systemd.rpm’ saved [2938656]

[root@rocky8_5 ~]# rmp -Uvh amagent-1.42.13-1.x86_64.systemd.rpm
-bash: rmp: command not found
[root@rocky8_5 ~]# rpm -Uvh amagent-1.42.13-1.x86_64.systemd.rpm
error: Failed dependencies:
yum-utils is needed by amagent-1.42.13-1.x86_64
[root@rocky8_5 ~]# dnf install yum
Last metadata expiration check: 0:15:07 ago on Fri 03 Feb 2023 09:40:07 AM UTC.
Dependencies resolved.
==================================================================================================================================
Package Architecture Version Repository Size
==================================================================================================================================
Installing:
yum noarch 4.7.0-11.el8 baseos 205 k

Transaction Summary
==================================================================================================================================
Install 1 Package

Total download size: 205 k
Installed size: 75 k
Is this ok [y/N]: n
Operation aborted.
[root@rocky8_5 ~]# dnf install yum-utils
Last metadata expiration check: 0:15:15 ago on Fri 03 Feb 2023 09:40:07 AM UTC.
Dependencies resolved.
==================================================================================================================================
Package Architecture Version Repository Size
==================================================================================================================================
Installing:
yum-utils noarch 4.0.21-14.1.el8 baseos 73 k

Transaction Summary
==================================================================================================================================
Install 1 Package

Total download size: 73 k
Installed size: 23 k
Is this ok [y/N]: y
Downloading Packages:
yum-utils-4.0.21-14.1.el8.noarch.rpm 1.8 MB/s | 73 kB 00:00
----------------------------------------------------------------------------------------------------------------------------------
Total 1.7 MB/s | 73 kB 00:00
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing : 1/1
Installing : yum-utils-4.0.21-14.1.el8.noarch 1/1
Running scriptlet: yum-utils-4.0.21-14.1.el8.noarch 1/1
Verifying : yum-utils-4.0.21-14.1.el8.noarch 1/1

Installed:
yum-utils-4.0.21-14.1.el8.noarch

Complete!
[root@rocky8_5 ~]# rpm -Uvh amagent-1.42.13-1.x86_64.systemd.rpm
Verifying... ################################# [100%]
Preparing... ################################# [100%]
Updating / installing...
1:amagent-1.42.13-1 ################################# [100%]
[root@rocky8_5 ~]# sudo /opt/amagent/amagent --setkey xxxxx-xxxx-xxx-xxxx
[root@rocky8_5 ~]# sudo service amagent start
Redirecting to /bin/systemctl start amagent.service

 

Reply